読者です 読者をやめる 読者になる 読者になる

あお日記

理系研究者のブログです。勉強したことや本の感想などを中心に残して行くつもりです。

Node-REDのインストール

Node-REDをnpmを使ってインストールする際に詰まったのでメモ。

バージョンはNode-REDがv0.13.1, Node.jsがv0.12.4 でした。

公式サイト (Node-RED) ではNode.jsをインストールしてnpmコマンドでOK!と書いてあるがやってみると下記のエラーが。

Node-RED has not been built. See README.md for details

調べて見るとnpmのバージョンが古いのが原因のようでした。
node-red command won't work after npm install · Issue #749 · node-red/node-red · GitHub

下記のコマンドを実行して再度Node-REDをインストールをしたら解決しました。

$ sudo npm install -g node-red